Verizon Developer Community Forum

Soap UI  XML
 |   |   |   |   | 
Author Message
kim

Beginner

Joined: 01/28/2010 05:58:43
Messages: 5

Hello,

I've gotten soap UI loaded, requested my API credentials which were emailed to my registered email. I can't seem to get soap UI to connect without a soap fault.

I've gotten my time synchronized to the server that the web service is on - I'm not getting that error any more. I've tried using my developer account password, and the password that was sent using the link on the network enabler portion of the site that emails the API password to you.

When setting up soap ui credentials, I followed the documentation on this site and left the password type "blank", I even tried PasswordText and PasswordDigest. Does anyone have any ideas? Could my account not be ready for the API yet, is there a way for me to find that out?

I've pasted my request and response below.




vidhu.joshua

Superstar

Joined: 11/17/2010 09:17:13
Messages: 23

Hi Kim,

Are you using SoapUI on Mac? We observed an issue on Mac where if you select "Password Text" using the mouse, the menu item does not get selected. Even if you are using a pc, please make sure to choose password text or your request will not validate correctly.

The workaround is to click on "Password Type" dropdown list, and while the drop-down menu is visible, hover the mouse to "PasswordText". At that point, press "enter/return" on the keyboard. That will select the "PasswordText" menu item.

Password Type has to be set to "PasswordText" for the authentication to succeed. Please let us know if this solves the issue..

Thanks
VJ
kim

Beginner

Joined: 01/28/2010 05:58:43
Messages: 5

Sorry for the delay in getting back to you.

I am using soapUI 3.6 on windows XP. I went in and changed my authentication type to passwordText manually, unchecked create timestamp/nonce, and I received a success.

Thank you much
stephenwsmith

Beginner

Joined: 01/21/2011 11:05:19
Messages: 5

Kim,

I am apparently having the same issue with the FailedAuthentication response. But in my example from the tutorial, even though I select "Example Credentials" as my Outgoing WSS, this is all I have for a header in my SoapUI window. I tried unchecking the two options you unchecked in the Security Configurations tab of the Getting Started SOAP window. I double-checked that PasswordText is the Password Type I have selected, but since I don't see the full header that you see, I can't double-check that that's what's going out. Any thoughts since you've gotten this to work?
kemi.ibitayo

Superstar

Joined: 07/21/2010 10:47:13
Messages: 82

Hi,

Please go ahead and trigger the 'Access your simulator credentials' again. There was an issue where the password was being overwritten that is now resolved.

http://developer.verizon.com/content/vdc/en/verizon-tools-apis/verizon_apis/network-api/napi-tutorials.html

Thank you
Kemi



This message was edited 1 time. Last update was at 10/16/2011 22:05:18

 |   |   |   |   | 
Go to: 
Go